Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

karlasweeney1 Offline
#1 Posted : Thursday, February 21, 2013 8:23:34 PM(UTC)
karlasweeney1

Rank: Advanced Member

Groups: Registered
Joined: 9/28/2010(UTC)
Posts: 34

Thanks: 19 times
I've had my G just over a year. I've never updated it because I've heard such horror stories, but I got a bunch of new carts for Christmas and finally decided to give it a go tonight. I've NEVER had a problem with my G. EVER. Near the end of the update it told me my G was unresponsive....I looked down and sure enough all of a sudden it was off. It told me to restart the Sync. I turned the G back on and restarted the Sync. Now my G won't stay on!!!

I turn it on and it says "loading" and then about the time it should get to the menu of the three little icons it turns off.

I am SICK. Did PC just kill my G under the guise of an update? I'm sure it's out of warranty, right?

What now? I want to throw up and kick the dog. I am seriously mad. I shudder to think about having to go through the Support Center tomorrow.....I've heard nothing much good about those calls.

Any advice? Anybody else have this problem? What happened?
Dragonfly50 Offline
#2 Posted : Thursday, February 21, 2013 9:21:46 PM(UTC)
Dragonfly50

Rank: Advanced Member

Groups: Registered
Joined: 5/3/2011(UTC)
Posts: 2,488
United States

Thanks: 1237 times
Was thanked: 1219 time(s) in 728 post(s)
It is worth a call.

I have only had good customer service experiences.

If your G is just past the 1 year date they may be able to do something.
Did you register it? Do you have the receipt? They will probably ask you this.

Make sure you tell them you have NEVER had any issues with it until you did this update.

There also may be something they can suggest you try to get it back up and running.

I suggest you call sooner rather than later.

Oh and don't kick the dog.

Hope this helps.
D-

Edited by user Thursday, February 21, 2013 9:22:52 PM(UTC)  | Reason: Not specified

 1 user thanked Dragonfly50 for this useful post.
karlasweeney1 on 2/22/2013(UTC)
karlasweeney1 Offline
#3 Posted : Friday, February 22, 2013 11:19:40 AM(UTC)
karlasweeney1

Rank: Advanced Member

Groups: Registered
Joined: 9/28/2010(UTC)
Posts: 34

Thanks: 19 times
Ok, I will update this in case some other poor soul finds themself in this predicament and comes across my original post.

I called PC this morning and got someone straight away. She was very helpful, sent me an email with step by step instructions on what I needed to do, and stayed on the phone with me until the process got underway. The email was a just in case, I didn't have to do anything once the process got started.

We did a restore, which means I lost all my project files. (Word to the wise...which I didn't know....you can and should back those up onto your computer!)

The process took about an 90 minutes, but my carts are all still there and the G is working fine, and is now fully updated.

Note - I was NOT under warranty but she was still able to get me going with little fuss.

SOOOOOO if you find yourself in this predicament CALL THEM. I would tell you how to do what she did for me, but I would hate to do that and then that either not fix your issue, or make it worse.

It's a happy Friday for me, with a good chance of heavy Gypsying this weekend! :)
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.212 seconds.
nebo-cricut-03